Back to overview
Maintenance
Maintenance of the AI CRM app
Oct 31 at 07:07pm EET
–
Oct 31 at 07:22pm EET
Affected services
app.teameight.ai
Resolved
Oct 31 at 07:07pm EET
We have finished the infra update.
Affected services
Resolved
Oct 31 at 07:07pm EET
We have finished the infra update.
Affected services